易语言调用ZMIN条码打印机动态链接库打印示例

Hits:34632018-10-12 09:57:24 Source: RFID打印机|RFID标签|国产条码打印机制造商_ZMIN深圳致明兴科技

 

易语言是一门以中文作为程序代码编程语言,其以“易”著称,创始人为吴涛。易语言早期版本的名字为E语言。其最早的版本的发布可追溯至2000年9月11日。创造易语言的初衷是进行用中文来编写程序的实践,方便中国人以中国人的思维编写程序,并不用再去学习西方思维。易语言的诞生极大的降低了编程的门槛和学习的难度。从2000年以来,易语言已经发展到一定的规模,功能上、用户数量上都十分可观。

 

易语言目前只支持32位应用,所以只能调用32位的dll(ZMPCL_x86.dll)。

 

部分代码如下:

 

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 打印机状态, 短整数型, 静态


打印机状态 = 连接打印机 (255)
.如果 (打印机状态 ≠ 0)
    信息框 (“请确认打印机连接状态”, 0, )
    返回 ()
.否则

.如果结束

清空缓冲区 ()
打印深度 (10)
打印速度 (40)
' 203dpi: 1MM=8dot
打印标签高度 (360, 16)  ' 45mm高
打印标签宽度 (400)  ' 50mm宽

打印内置文本 (24, 24, 0, 2, 1, 1, 78, “ZMIN1234567”)  ' N字符的ASCII码值78  B字符的ASCII码值66

打印TrueType文本 (24, 64, 32, 0, “宋体”, 1, 400, 0, 0, 0, “A1”, “致明兴条码打印机测试”)
打印TrueType文本 (24, 120, 32, 0, “黑体”, 1, 400, 0, 0, 0, “A2”, “黑体致明兴Printer测试”)

创建一维条形码 (24, 180, 0, “1A”, 2, 3, 80, 66, “123456789”)  ' N字符的ASCII码值78  B字符的ASCII码值66

执行打印工作 (1, 1)
断开打印机 ()

 

示例源码下载:http://www.zmin.com.cn/upload/ZMINDemo_e.rar

 

 

 

 

【Editor:zmin